# System Requirements

General Requirements

  • ExpressionEngine 2, 2.10.2 or greater; ExpressionEngine 3, 3.1.0 or greater

Control Panel interface use requirements

  • Internet Explorer 9 or greater
  • Chrome (tested with 47.0.2526.106)
  • Firefox (tested with 41.0.2)
  • Safari (Mac) (tested with 9.0.2)

Compatibility

All field types in Field Limits are compatible with

In addition, the EE 2 version is compatible with Blocks.

# Installing Or Updating

Installing and updating Field Limits is very easy.

ExpressionEngine 3

  1. Download the latest release tagged for ExpressionEngine 3 from the GitHub Releases page.
    • Note that releases for EE 3 will not be tagged with the suffix -ee2. If the release does have this suffix, it is for EE 2.
  2. Unarchive the file and copy system/user/addons/field_limits to the same directory location in your EE instance
    • If you are updating, replace the existing field_limits directory
  3. Log in to your EE control panel and navigate to the Add-on Manager
  4. Scroll down to the “Third Party” section, locate “Field Limits” in the list and click “Install” or “Update”

Field Limits for ExpressionEngine 3 is now installed or updated.

ExpressionEngine 3

  1. Download the latest release tagged for ExpressionEngine 2 from the GitHub Releases page.
    • Note that releases for EE 2 will be tagged with the suffix -ee2. If the release does not have this suffix, it is for EE 3.
  2. Unarchive the file and copy system/expressionengine/third_party/field_limits to the third_party addons system directory
    • If you are updating, replace the existing field_limits directory
  3. Log in to your EE control panel and navigate to “Add-Ons > Field Types”
  4. If you are installing field_limits, locate the “Field Limits” field types in the list and click install on each of them.
    • Note that if you are only updating Field Limits, merely visiting this page triggers the update

Field Limits for ExpressionEngine 2 is now installed or updated.